WordPressが稼働しているサーバのPHPバージョンに注意

この記事を読むのに必要な時間は約 2 分です。

先月から急増しているのがWordPressのsyntax error対応です。特にコンタクトフォーム7とテーマのfunctionでエラーが発生しています。

サポートしたサイトでの原因は、すべてPHP5.6で稼働していたことでした。

サーバのコントロールパネルからデフォルトPHPのバージョンを7.4または8に上げることで解消します。
ただし、テーマで発生しているエラーに関しては、テーマの開発そのものが止まっている場合が多いので、これを機会に変更することをオススメします。

なお、弊社のおすすめは株式会社ベクトルさんのkatawaraです。

買い切り型ですが、サポートが続いているのと、拡張ブロックが使いやすいことをオススメします。

WordPressのトラブルで悩んでいる場合、お気軽にお問い合わせください。